Free and Open-source video streaming suite. https://miracle-tv.live
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 

58 lines
2.0 KiB

{
"name": "miracle-tv",
"version": "0.1.0",
"main": "server.ts",
"author": "Dale <deiru2k@gmail.com>",
"license": "MIT",
"private": false,
"engines" : { "node" : ">=12.0" },
"scripts": {
"test": "./bin/testServer.sh",
"test:mocha": "NODE_PATH=./src ./node_modules/.bin/mocha",
"watch:server": "$node_modules/.bin/nodemon -e ts --exec \"yarn run:server\"",
"run:server": "$node_modules/.bin/ts-node -r $node_modules/tsconfig-paths/register ./src/server/server.ts",
"build:server": "./bin/buildServer.sh",
"test:server": "NODE_PATH=./src $node_modules/.bin/mocha -r ts-node/register -r tsconfig-paths/register test/server/**/*.spec.ts --configPath ./config/test.json",
"migrate:add": "$node_modules/.bin/knex migrate:make --migrations-directory .\\migrations",
"migrate:local": "$node_modules/.bin/knex migrate:latest",
"migrate:sqlite": "yarn migrate:local ./config/sqlite.json",
"migrate:test": "yarn migrate:local ./config/test.json"
},
"postInstall": "chmod +x ./bin/*",
"dependencies": {
"@types/js-md5": "^0.4.2",
"ajv": "^6.10.0",
"cors": "^2.8.5",
"express": "^4.17.0",
"js-md5": "^0.7.3",
"knex": "^0.16.5",
"minimist": "^1.2.0",
"miracle-tv-shared": "git+https://code.gensokyo.social/Gensokyo.social/miracle-tv-shared.git",
"node-pre-gyp": "^0.15.0",
"pg": "^8.3.0",
"ramda": "^0.26.1",
"sqlite3": "^5.0.0",
"supertest": "^4.0.2",
"uuid": "^3.3.2",
"@types/ajv": "^1.0.0",
"@types/chai": "^4.1.7",
"@types/cors": "^2.8.5",
"@types/express": "^4.16.1",
"@types/minimist": "^1.2.0",
"@types/mocha": "^5.2.6",
"@types/node": "^12.0.2",
"@types/ramda": "^0.26.8",
"@types/supertest": "^2.0.10",
"@types/uuid": "^3.4.4",
"chai": "^4.2.0",
"json-loader": "^0.5.7",
"mocha": "^6.1.4",
"nodemon": "^1.19.1",
"ts-loader": "^6.0.1",
"ts-node": "^8.1.0",
"tsconfig-paths": "^3.8.0",
"tslint": "^5.18.0",
"tslint-config-airbnb": "^5.11.1",
"typescript": "^3.4.5"
}
}