Frontend for Miracle TV
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

60 lines
1.8KB

  1. {
  2. "name": "miracle-tv-frontend",
  3. "version": "0.1.0",
  4. "private": true,
  5. "scripts": {
  6. "serve": "vue-cli-service serve",
  7. "build": "vue-cli-service build",
  8. "test:unit": "vue-cli-service test:unit",
  9. "lint": "vue-cli-service lint",
  10. "storybook": "start-storybook -p 6006",
  11. "build-storybook": "build-storybook"
  12. },
  13. "dependencies": {
  14. "@types/axios": "^0.14.0",
  15. "@types/chai": "^4.2.11",
  16. "@types/mocha": "^5.2.4",
  17. "@types/ramda": "^0.27.14",
  18. "@typescript-eslint/eslint-plugin": "^2.33.0",
  19. "@typescript-eslint/parser": "^2.33.0",
  20. "@vue/cli-plugin-eslint": "~4.5.0",
  21. "@vue/cli-plugin-router": "~4.5.0",
  22. "@vue/cli-plugin-typescript": "~4.5.0",
  23. "@vue/cli-plugin-unit-mocha": "~4.5.0",
  24. "@vue/cli-plugin-vuex": "~4.5.0",
  25. "@vue/cli-service": "~4.5.0",
  26. "@vue/eslint-config-airbnb": "^5.0.2",
  27. "@vue/eslint-config-typescript": "^5.0.2",
  28. "@vue/test-utils": "^1.0.3",
  29. "axios": "^0.19.2",
  30. "chai": "^4.1.2",
  31. "eslint": "^6.7.2",
  32. "eslint-plugin-import": "^2.20.2",
  33. "eslint-plugin-vue": "^6.2.2",
  34. "flexboxgrid": "^6.3.1",
  35. "miracle-tv-shared": "git+https://code.gensokyo.social/Gensokyo.social/miracle-tv-shared.git#c2f78e7633",
  36. "ramda": "^0.27.1",
  37. "sass": "^1.26.10",
  38. "sass-loader": "^10.0.1",
  39. "tslib": "^2.0.1",
  40. "typescript": "~3.9.3",
  41. "url-loader": "^4.1.0",
  42. "vue": "^2.6.11",
  43. "vue-class-component": "^7.2.3",
  44. "vue-property-decorator": "^8.4.2",
  45. "vue-router": "^3.2.0",
  46. "vue-template-compiler": "^2.6.11",
  47. "vuex": "^3.4.0"
  48. },
  49. "devDependencies": {
  50. "@babel/core": "^7.11.5",
  51. "@storybook/addon-actions": "^6.0.21",
  52. "@storybook/addon-essentials": "^6.0.21",
  53. "@storybook/addon-links": "^6.0.21",
  54. "@storybook/vue": "^6.0.21",
  55. "babel-loader": "^8.1.0",
  56. "react-is": "^16.13.1",
  57. "vls": "^0.4.2"
  58. }
  59. }